Voraussetzungen

Hier wird erklärt welche Voraussetzungen Ihr Server und Ihre Contao Installation mitbringen muss, damit die Erweiterung problemlos und fehlerfrei eingesetzt werden.

1. Unterstützte Contao Versionen

  • Contao 3.4.0 bis 3.5.x
  • Contao 4.4.0 bis 4.4.x

Das heißt nicht, dass die Erweiterung nicht auch mit anderen Versionen von Contao funktioniert. Wir arbeiten daran, die Erweiterung auch für Contao 4.5 und 4.6 kompatibel zu machen.

2. Nicht kompatible Contao Versionen

2.1 Contao 3.2 und älter

Ältere Versionen von Contao werden von älteren Versionen des Erweiterten Produktshops unterstützt. Um die aktuellste Version des Erweiterte Produktshops z.B. für Contao 3.2 kompatibel zu machen, wären erhebliche Anpassungen nötig.

Falls Sie Contao 3.2 einsetzen, aktualisieren Sie auf Contao 3.5 - der Langzeit Support läuft noch bis 2019.

2.2 Contao 4

Eine Contao 4 kompatible Version wird erst erscheinen sobald Contao 4 in einer fortgeschrittenen, fehlerfreien Version veröffentlicht wurde.

3. Abhängigkeit zu anderen Erweiterungen

Der Erweiterte Produktkatalog ist von folgenden Erweiterungen abhängig:

3.1 Contao Produktkatalog

Der Erweiterte Produktkatalog setzt funktional auf dem Contao Produktkatalog auf. Dieser ist daher zwingend erforderlich.

Die Installation des Erweiterten Produktkatalogs ist jederzeit auf einem bestehenden System mit dem einfachen Produktkatalog möglich. Bitte legen Sie ein Datenbank-Backup an. In der Regel ist das Upgrade aber problemlos. Alle Produktdaten bleiben erhalten.

3.2 Sonstige Erweiterungen

Folgende Erweiterung ist zwingend erforderlich:

  • Tags [tags] - Wir arbeiten daran die Erweiterung zu einer optionalen Erweiterung zu machen

Folgende Erweiterung ist optional:

  • Haste - Wird nur gebraucht, wenn Sie Varianten einsetzen und diese im Frontend wählbar gestalten wollen

Die Abhängigkeiten werden bei Installation über den Erweiterungskatalog automatisch mit installiert.

4. PHP-Version

Welche Version von PHP zum Einsatz kommen muss, ist in erster Linie abhängig von der installierten Contao-Version. Bei den meisten Versionen von Contao 3.5 ist mindestens PHP 5.4 erforderlich. Zudem läuft es fehlerfrei mit PHP 5.5 und 5.6.

Einen Unterschied gibt es nur bei PHP 7. Diese Version funktioniert ab Contao 3.5.5, in den meisten Bereichen des Produktkatalogs, aber noch nicht in der neuesten Version vom Contao Produktshop.

Zurück