Voraussetzungen

Hier wird erklärt welche Voraussetzungen Ihr Server und Ihre Contao Installation mitbringen muss, damit die Erweiterung problemlos und fehlerfrei eingesetzt werden.

Unterstützte PHP Versionen

Die Contao Erweiterung Contao Gästebuch ist grundsätzlich voll kompatibel mit den folgenden PHP-Versionen:

PHP 5.4 bis PHP 7.4

Es ist durchaus möglich, dass die Erweiterung auch mit anderen PHP-Versionen lauffähig ist. Wir haben dazu nur noch keine ausreichenden Daten aus Produkivumgebungen. Sollte Ihr Server die genannten PHP-Versionen nicht gewährleisten, so testen Sie die Erweiterung bitte in einer Testumgebung und nicht in einer Produktivumgebung, da die volle Funktionalität dann nicht gewährleistet ist.

Erforderliche Contao Version

Contao 4 | Contao 4.4.0 bis 4.9.22
Contao 3 | Contao 3.3.0 bis 3.5.35

Es ist möglich, dass die Erweiterung auch schon mit höheren Versionen von Contao funktioniert. Auf Anfrage können wir die Erweiterung auch offiziell für Contao 4.10, 4.11 und 4.12 kompatibel machen. Spätestens im 2. Quartal 2022 wird eine Contao 4.13 LTS kompatible Version erscheinen. 

Unterstützte Contao Versionen

Contao 3.4.0 bis Contao 3.5.x werden offiziell unterstützt.

Dies deckt die meisten aktuellen Installationen von Contao ab.

Nicht kompatible Contao Versionen

Contao 3.2 und älter

Ältere Versionen von Contao werden von älteren Versionen des Support Ticket Systems unterstützt. Um die aktuellste Version desSupport Ticket Systems z.B. für Contao 3.2 kompatibel zu machen, wären erhebliche Anpassungen nötig.

Falls Sie Contao 3.2 oder Contao 3.3 einsetzen, aktualisieren Sie bitte zuvor auf Contao 3.5 - der Langzeit Support läuft noch bis 2019.

Wenn Sie zwingend auf eine ältere Version angewiesen sind, können wir die Erweiterung wahrscheinlich kostenpflichtig auch für eine ältere Version kompatibel machen. Kontaktieren Sie uns in diesem Fall bitte.

Contao 4.6

Eine Contao 4.6 kompatible Version wird in den nächsten Monaten erscheinen.

Abhängigkeit zu anderen Erweiterungen

Das Gästebuch ist von keinen anderen Erweiterungen abhängig.

PHP-Version

Die Contao 3 Version der Erweiterung ist kompatibel mit PHP 5.4, 5.5 und 5.6 sowie PHP 7.0 und 7.1.

Die Contao 4 Version der Erweiterung ist zudem kompatibel mit PHP 7.0 und 7.1.

Das Gästebuch funktioniert wahrscheinlich noch nicht in allen Modulen mit PHP 7.2. Im Laufe des Jahres 2019 wird auch eine PHP 7.2 kompatible Version veröffentlicht.

Zurück

Fragen und Feedback

Haben Sie noch Fragen oder gefällt Ihnen diese Seite des Handbuchs? Wir freuen uns auf Ihr Feedback.

Bewertung
Datenschutz*
Bitte rechnen Sie 9 plus 8.