Voraussetzungen

Hier wird erklärt welche Voraussetzungen Ihr Server und Ihre Contao Installation mitbringen muss, damit die Erweiterung problemlos und fehlerfrei eingesetzt werden.

Unterstützte PHP Versionen

Die Contao Erweiterung Automatische Weiterleitungen ist grundsätzlich voll kompatibel mit den folgenden PHP-Versionen:

PHP 5.4 bis PHP 8.1

Es ist durchaus möglich, dass die Erweiterung auch mit anderen PHP-Versionen lauffähig ist. Wir haben dazu nur noch keine ausreichenden Daten aus Produkivumgebungen. Sollte Ihr Server die genannten PHP-Versionen nicht gewährleisten, so testen Sie die Erweiterung bitte in einer Testumgebung und nicht in einer Produktivumgebung, da die volle Funktionalität dann nicht gewährleistet ist.

Erforderliche Contao Version

Contao 4 | Contao 4.4.0 bis 4.9.22
Contao 3 | Contao 3.1.0 bis 3.5.36

Es ist möglich, dass die Erweiterung auch schon mit höheren Versionen von Contao funktioniert. Auf Anfrage können wir die Erweiterung auch offiziell für Contao 4.10, 4.11 und 4.12 kompatibel machen. Spätestens im 2. Quartal 2022 wird eine Contao 4.13 LTS kompatible Version erscheinen. 

Htaccess

Wenn Sie einen Apache-Server haben, sollten Sie in der Htaccess-Datei auf jeden Fall folgende Zeile notieren:

 ErrorDocument 404 /

Nur so können zweifelsfrei alle (oder zumindest die meisten) 404-Fehler erfasst werden.

Nicht kompatible Contao Versionen

Contao 3.0 und älter

Ältere Versionen von Contao werden werden derzeit nicht unterstützt. Wenn Sie eine ältere Version einsetzen, kontaktieren Sie uns, ggf. können wir Abhilfe schaffen.

Abhängigkeit zu anderen Erweiterungen

Die Erweiterung ist von keinen anderen Erweiterungen unabhängig.

Zurück

Fragen und Feedback

Haben Sie noch Fragen oder gefällt Ihnen diese Seite des Handbuchs? Wir freuen uns auf Ihr Feedback.

Bewertung
Datenschutz*
Was ist die Summe aus 9 und 5?